Contourner l'avertissement de sécurité d'Hadoop sur OSX

Parfois en utilisant Hadoop en local sur OSX, il arrive qu'on ait un désagréable avertissement relatif à la sécurité de la JVM :

hadoop fs -rm -Rf products
2013-04-28 18:36:52.052 java[16109:1203] Unable to load realm info from SCDynamicStore

Il suffit de mettre dans les options Hadoop la ligne suivante et tout rentre dans l'ordre :

export HADOOP_OPTS="-Djava.security.krb5.realm= -Djava.security.krb5.kdc="